Monday, September 26, 2016

vmware esxi 6 on Intel NUC


Just some notes for now, later will detail how install worked out


http://www.virten.net/2015/03/esxi-6-0-image-for-intel-nuc/

xx

install notes:

http://www.ivobeerens.nl/2016/02/24/intel-nuc-6th-generation-as-home-server/

http://www.ivobeerens.nl/2011/09/17/create-a-bootable-vmware-esxi-5-usb-stick-in-windows-and-perform-a-scripted-installation/

xx
http://tekhead.it/blog/category/nanolab/
xx
technique I used, rufus

http://www.virten.net/2016/01/vmware-homeserver-esxi-on-6th-gen-intel-nuc/

Installation

No customization is required to install the latest ESXi 5.5 and ESXi 6.0 versions on 6th Gen NUCs. You can use the images provided by VMware to Install ESXi:
The simplest way to install ESXi is by using the original ISO and Rufus to create a bootable ESXi Installer USB Flash Drive.

****

Download Rufus.  I have 2.9.934
http://rufus.akeo.ie/



















Set the above options, and remember to select the disk image next to
"Create a bootable disk using" and select the iso file to be bootable.

Vmware ISO 6.0 was downloaded from here:

Vmware FREE-ESXI6

A link to the current vmware may have to be gotten by following links to get an evaluation version.  The above is for reference, and is the version my systems run.


xx

Saturday, September 24, 2016

find / cpio directory copy / move / archive info




http://bradthemad.org/tech/notes/cpio_directory.php

Create a cpio archive:
localhost% find path/ -depth -print | cpio -oaV > archive.cpio
localhost% find path/ -depth -print | cpio -oaV -O archive.cpio
Create a cpio archive and compress it:
localhost% find path/ -depth -print | cpio -oaV | gzip -c > archive.cpio.gz
 
Extract a compressed cpio archive:
cd to parent directory of location to install.
gzip -cd path-to-cpio-gz | cpio -idmv
<uncompress to stdout>  pipe <cpio install stream from stdin>
 
http://superuser.com/questions/31078/cpio-basic-extract-command-tar-xzvf-equivalent 
 
Extract a cpio archive:
localhost% cpio -imVd < archive.cpio
localhost% cpio -imVd -I archive.cpio
List the contents of a cpio archive:
localhost% cpio -it < archive.cpio
localhost% cpio -it -I archive.cpio
Use cpio copy-pass to copy a directory structure to another location:
localhost% find path/ -depth -print | cpio -pamVd /new/parent/dir

cpio over ssh

To cpio a local directory, send the output to ssh and feed it to cpio on a remote host:
localhost% find path/ -depth -print | cpio -oaV | ssh user@host 'cpio -imVd'
Ssh to a remote host, cpio a remote directory, and get its output locally:
localhost% ssh user@host "find path/ -depth -print | cpio -oaV" | cpio -imVd 
 
 

xx

Ubuntu / rsync backup


 https://www.digitalocean.com/community/tutorials/how-to-upgrade-ubuntu-12-04-lts-to-ubuntu-14-04-lts

 The aAX flags tell rsync to preserve important file attributes like permissions, ownerships, and modification times. If you are using Docker or another virtualization tool, you should add the S flag so that rsync properly handles sparse files, like virtual storage.

sudo rsync -aAXv --exclude={"/dev/*","/proc/*","/sys/*","/tmp/*","/run/*","/mnt/*","/media/*","/lost+found"} -e 'ssh -i /path/to/private_key' root@SERVER_IP_ADDRESS:/* ~/backup/
 
sudo rsync -aAXv --exclude={"/dev/*","/proc/*","/sys/*","/tmp/*","/run/*", \
"/mnt/*","/media/*","/lost+found"} -e 'ssh -i /path/to/private_key' \
root@SERVER_IP_ADDRESS:/* ~/backup/ 

If you need to restore parts of your server files later on, you can use rsync 
again with the source and destination parameters reversed, like so:  
 
sudo rsync -aAXv -e 'ssh -i /path/to/private_key' ~/backup/ root@SERVER_IP_ADDRESS:/*

xx
 
How to deal with "/path/to/private_key" 

http://www.cyberciti.biz/faq/force-ssh-client-to-use-given-private-key-identity-file/

example:

ssh -i /path/to/id_rsa user@server.nixcraft.com
ssh -i /path/to/id_dsa user@server2.nixcraft.net.in

To use /backup/home/user/.ssh/id_dsa, enter:

ssh -i /backup/home/user/.ssh/id_dsa user@unixserver1.nixcraft.com


xx 

Ubuntu / rsync backup


 https://www.digitalocean.com/community/tutorials/how-to-upgrade-ubuntu-12-04-lts-to-ubuntu-14-04-lts

 The aAX flags tell rsync to preserve important file attributes like permissions, ownerships, and modification times. If you are using Docker or another virtualization tool, you should add the S flag so that rsync properly handles sparse files, like virtual storage.

sudo rsync -aAXv --exclude={"/dev/*","/proc/*","/sys/*","/tmp/*","/run/*","/mnt/*","/media/*","/lost+found"} -e 'ssh -i /path/to/private_key' root@SERVER_IP_ADDRESS:/* ~/backup/
 
sudo rsync -aAXv --exclude={"/dev/*","/proc/*","/sys/*","/tmp/*","/run/*", \
"/mnt/*","/media/*","/lost+found"} -e 'ssh -i /path/to/private_key' \
root@SERVER_IP_ADDRESS:/* ~/backup/ 

If you need to restore parts of your server files later on, you can use rsync 
again with the source and destination parameters reversed, like so:  
 
sudo rsync -aAXv -e 'ssh -i /path/to/private_key' ~/backup/ root@SERVER_IP_ADDRESS:/*

xx
 
How to deal with "/path/to/private_key" 

http://www.cyberciti.biz/faq/force-ssh-client-to-use-given-private-key-identity-file/

example:

ssh -i /path/to/id_rsa user@server.nixcraft.com
ssh -i /path/to/id_dsa user@server2.nixcraft.net.in

To use /backup/home/user/.ssh/id_dsa, enter:

ssh -i /backup/home/user/.ssh/id_dsa user@unixserver1.nixcraft.com


xx 

Tuesday, September 20, 2016

Windows 7 setup notes


set up printers:

HP 4500 printer, need hp driver:
http://support.hp.com/us-en/drivers/selfservice/HP-Officejet-4500-All-in-One-Printer-Series---G5/3919445/model/3919446

HP 2015 printer installs from the ip of the printer on 7, 8.1 and win 10

Install firefox extensions

Install Putty, games, firefox, set up remote desktops

Install vmware client manager 5, or 6 for appropriate host for install.


Sunday, September 18, 2016

possible workaround to readynas windows 10 share problem. (relevant to developer win 10 installs)


Note on removing credential (If I understand it), as a workaround fix for broken Windows 10 fix. 

Windows 10 upgrades to the developer releases seem to be invalidating stored credentials with each update with some regularity.  if you have a drive share mount with stored credentials, or on another front though not with the readynas nas, stored logins for say remote desktop, you have to reinput them.

That was working up to the latest 9/14 or 9/16 set of updates.  now it seems to retain the credential and not let you easily reinput the login, or share.

And it was not accepting any password on other shares, even valid ones.

A fellow on the Readynas forum (where this became a topic) suggested a workaround worth documenting.

Thanks to Readynas forum user nayadn for this.

nayadn (Aspirant) posted a new reply in R6000 Series AC WiFi Routers on 2016-09-17 07:32 AM :


Re: Can no longer access ReadyShare drives on Windows 10


i googled again the error and i came up with a sideway solution
go into user account in control panel
if you're in windows 10 select manage your credentials this will open 2 options
web credentials and windows credentials
head to windows credentials and add a new windows credential
enter the location of the drive \\readyshare on the first line
your windows user name in the second line
your windows password in the third line
and you're done, you should see the drive under network and be able to access it as before
good luck

Friday, September 16, 2016

Block updates on Windows 10


Have to remove updates to make Readynas and shares work again.  Microsoft Windows 10 update this week fucked it completely up, with some update, so have to identify and remove updates till they work again, then ban the update that is causing it.

http://www.howtogeek.com/223864/how-to-uninstall-and-block-updates-and-drivers-on-windows-10/

Open the Settings app and select “Update & security.” Under Windows Update, scroll down and select “Advanced options,” and then select “View your update history.”

Open Settings and navigate to Update & security > Windows Update > Advanced options > View your update history. You’ll see a link reading “Uninstall updates” at the top of the update history list.

This link takes you to the “Uninstall an update” dialog, where you can uninstall an individual Windows Update if it’s causing problems on your system.

Prevent a Driver or Update From Being Installed from Windows Update

https://support.microsoft.com/en-us/kb/3073930

When you run this troubleshooter, it will search for available updates and allow you to “hide” them, preventing Windows from automatically installing them. In the future, you can run this troubleshooter again and unhide the updates when you want to install them.

If you want to temporarily prevent Windows from automatically downloading and installing any updates, you can do it without using the above tool to block updates. Just set your current Internet connection as “metered” and Windows won’t download updates while connected to it — at least until you tell Windows the connection isn’t metered anymore.

Extra, to do a blanket uninstall if possible:

Restore to system restore point, remove all updates after that point:
  1. Right-click (or press and hold) the Start button, and then select Control Panel.
  2. Search Control Panel for Recovery.
  3. Select Recovery > Open System Restore > Next.
  4. Choose the restore point related to the problematic app, driver, or update, and then select Next > Finish.
 xx

Thursday, September 15, 2016

windows group policy editing


https://support.microsoft.com/en-us/kb/968264

This is a note about a specific polity, but shows how to get into policy editing

To work around this behavior, follow these steps:
  1. On the Management Server, click Start, click Run, type gpedit.msc, and then click OK.
  2. Under Computer Configuration, expand Windows Settings, expand Security Settings, expand Local Policies, and then expand Security Options.
  3. In the Policy pane, right-click Network access: Do not allow storage of credentials or .NET Passports for network authentication, click Properties, click Disabled, and then click OK.

Monday, September 12, 2016

Freya OS notes

Freya is a modified Ubuntu.  Some notes on changing the desktop and adding tools to make it useful are here.

Chrome:

https://johnsdeveloperblog.wordpress.com/2015/04/22/some-things-to-do-after-installing-elementary-os-freya/

XRDP setup:


sudo apt-get update
sudo apt-get install xfce4

echo xfce4-session >~/.xsession
sudo service xrdp restart

xx

xx

Thursday, September 8, 2016

Output from installing Chrome Browser on Rasbian


Rather than clutter the instructional notes, pasting the mess that came out of the install here.

There are a number of recommended installs called out by the install procedure at the end as the browser is installed.  Need to see if any of them are needed as a followup.



wget -qO - http://bintray.com/user/downloadSubjectPublicKey?username=bintray | sudo apt-key add -
echo "deb http://dl.bintray.com/kusti8/chromium-rpi jessie main" | sudo tee -a /etc/apt/sources.list
sudo apt-get update
sudo apt-get install chromium-browser rpi-youtube -y

pi@raspberrypi:~/work/chrome $ sudo apt-get update
Ign http://dl.bintray.com jessie InRelease
Get:1 http://dl.bintray.com jessie Release.gpg [821 B]                                                
Get:2 http://dl.bintray.com jessie Release [5,186 B]                                                                       
Hit http://mirrordirector.raspbian.org jessie InRelease                                                   
Get:3 http://dl.bintray.com jessie/main armhf Packages [5,182 B]                                          
Hit http://mirrordirector.raspbian.org jessie/main armhf Packages                                                
Hit http://archive.raspberrypi.org jessie InRelease                                 
Hit http://mirrordirector.raspbian.org jessie/contrib armhf Packages                   
Hit http://archive.raspberrypi.org jessie/main armhf Packages 
Hit http://mirrordirector.raspbian.org jessie/non-free armhf Packages
Hit http://archive.raspberrypi.org jessie/ui armhf Packages       
Hit http://mirrordirector.raspbian.org jessie/rpi armhf Packages                        
Ign http://dl.bintray.com jessie/main Translation-en_GB                                 
Ign http://dl.bintray.com jessie/main Translation-en              
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB  
Ign http://archive.raspberrypi.org jessie/main Translation-en     
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
Ign http://archive.raspberrypi.org jessie/ui Translation-en       
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB                                                    
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en                                                       
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB                                                       
Ign http://mirrordirector.raspbian.org jessie/main Translation-en                                                          
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB                                                   
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en                                                      
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB                                                        
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en                                                           
Fetched 11.2 kB in 14s (756 B/s)                                                                                           
Reading package lists... Done
pi@raspberrypi:~/work/chrome $ sudo apt-get install chromium-browser rpi-youtube -y
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following extra packages will be installed:
  chromium-browser-l10n chromium-codecs-ffmpeg-extra geoclue-2.0 kweb libjavascriptcoregtk-1.0-0 libmbim-glib4
  libmbim-proxy libmm-glib0 libqmi-glib1 libwebkitgtk-1.0-0 libwebkitgtk-1.0-common menu modemmanager
Suggested packages:
  webaccounts-chromium-extension unity-chromium-extension adobe-flashplugin menu-l10n
The following NEW packages will be installed:
  chromium-browser chromium-browser-l10n chromium-codecs-ffmpeg-extra geoclue-2.0 kweb libjavascriptcoregtk-1.0-0
  libmbim-glib4 libmbim-proxy libmm-glib0 libqmi-glib1 libwebkitgtk-1.0-0 libwebkitgtk-1.0-common menu modemmanager
  rpi-youtube
0 upgraded, 15 newly installed, 0 to remove and 73 not upgraded.
Need to get 74.5 MB of archives.
After this operation, 243 MB of additional disk space will be used.
Get:1 http://mirrordirector.raspbian.org/raspbian/ jessie/main libjavascriptcoregtk-1.0-0 armhf 2.4.9-1~deb8u1+rpi1 [1,190 kB]
Get:2 http://dl.bintray.com/kusti8/chromium-rpi/ jessie/main chromium-codecs-ffmpeg-extra armhf 51.0.2704.79-0ubuntu0.14.04.1.1121 [801 kB]
Get:3 http://mirrordirector.raspbian.org/raspbian/ jessie/main libmbim-glib4 armhf 1.10.0-2.1 [53.5 kB]
Get:4 http://mirrordirector.raspbian.org/raspbian/ jessie/main libmm-glib0 armhf 1.4.0-1 [135 kB]
Get:5 http://mirrordirector.raspbian.org/raspbian/ jessie/main libqmi-glib1 armhf 1.10.2-2 [302 kB]
Get:6 http://mirrordirector.raspbian.org/raspbian/ jessie/main libwebkitgtk-1.0-common all 2.4.9-1~deb8u1+rpi1 [451 kB]
Get:7 http://dl.bintray.com/kusti8/chromium-rpi/ jessie/main chromium-browser armhf 51.0.2704.79-0ubuntu0.14.04.1.1121 [58.3 MB]
Get:8 http://mirrordirector.raspbian.org/raspbian/ jessie/main libwebkitgtk-1.0-0 armhf 2.4.9-1~deb8u1+rpi1 [6,262 kB]     
Get:9 http://mirrordirector.raspbian.org/raspbian/ jessie/main geoclue-2.0 armhf 2.1.10-2 [61.4 kB]                        
Get:10 http://mirrordirector.raspbian.org/raspbian/ jessie/main libmbim-proxy armhf 1.10.0-2.1 [6,464 B]                   
Get:11 http://mirrordirector.raspbian.org/raspbian/ jessie/main menu armhf 2.1.47 [358 kB]                                 
Get:12 http://mirrordirector.raspbian.org/raspbian/ jessie/main modemmanager armhf 1.4.0-1 [465 kB]                        
Get:13 http://dl.bintray.com/kusti8/chromium-rpi/ jessie/main chromium-browser-l10n all 51.0.2704.79-0ubuntu0.14.04.1.1121 [3,246 kB]
Get:14 http://dl.bintray.com/kusti8/chromium-rpi/ jessie/main kweb armhf 1.7.4-1 [2,869 kB]                                
Get:15 http://dl.bintray.com/kusti8/chromium-rpi/ jessie/main rpi-youtube armhf 5.1.0-1 [2,562 B]                          
Fetched 74.5 MB in 27s (2,668 kB/s)                                                                                        
Selecting previously unselected package chromium-codecs-ffmpeg-extra.
(Reading database ... 126549 files and directories currently installed.)
Preparing to unpack .../chromium-codecs-ffmpeg-extra_51.0.2704.79-0ubuntu0.14.04.1.1121_armhf.deb ...
Unpacking chromium-codecs-ffmpeg-extra (51.0.2704.79-0ubuntu0.14.04.1.1121) ...
Selecting previously unselected package chromium-browser.
Preparing to unpack .../chromium-browser_51.0.2704.79-0ubuntu0.14.04.1.1121_armhf.deb ...
Unpacking chromium-browser (51.0.2704.79-0ubuntu0.14.04.1.1121) ...
Selecting previously unselected package chromium-browser-l10n.
Preparing to unpack .../chromium-browser-l10n_51.0.2704.79-0ubuntu0.14.04.1.1121_all.deb ...
Unpacking chromium-browser-l10n (51.0.2704.79-0ubuntu0.14.04.1.1121) ...
Selecting previously unselected package libjavascriptcoregtk-1.0-0:armhf.
Preparing to unpack .../libjavascriptcoregtk-1.0-0_2.4.9-1~deb8u1+rpi1_armhf.deb ...
Unpacking libjavascriptcoregtk-1.0-0:armhf (2.4.9-1~deb8u1+rpi1) ...
Selecting previously unselected package libmbim-glib4:armhf.
Preparing to unpack .../libmbim-glib4_1.10.0-2.1_armhf.deb ...
Unpacking libmbim-glib4:armhf (1.10.0-2.1) ...
Selecting previously unselected package libmm-glib0:armhf.
Preparing to unpack .../libmm-glib0_1.4.0-1_armhf.deb ...
Unpacking libmm-glib0:armhf (1.4.0-1) ...
Selecting previously unselected package libqmi-glib1:armhf.
Preparing to unpack .../libqmi-glib1_1.10.2-2_armhf.deb ...
Unpacking libqmi-glib1:armhf (1.10.2-2) ...
Selecting previously unselected package libwebkitgtk-1.0-common.
Preparing to unpack .../libwebkitgtk-1.0-common_2.4.9-1~deb8u1+rpi1_all.deb ...
Unpacking libwebkitgtk-1.0-common (2.4.9-1~deb8u1+rpi1) ...
Selecting previously unselected package libwebkitgtk-1.0-0:armhf.
Preparing to unpack .../libwebkitgtk-1.0-0_2.4.9-1~deb8u1+rpi1_armhf.deb ...
Unpacking libwebkitgtk-1.0-0:armhf (2.4.9-1~deb8u1+rpi1) ...
Selecting previously unselected package geoclue-2.0.
Preparing to unpack .../geoclue-2.0_2.1.10-2_armhf.deb ...
Unpacking geoclue-2.0 (2.1.10-2) ...
Selecting previously unselected package libmbim-proxy.
Preparing to unpack .../libmbim-proxy_1.10.0-2.1_armhf.deb ...
Unpacking libmbim-proxy (1.10.0-2.1) ...
Selecting previously unselected package menu.
Preparing to unpack .../archives/menu_2.1.47_armhf.deb ...
Unpacking menu (2.1.47) ...
Selecting previously unselected package modemmanager.
Preparing to unpack .../modemmanager_1.4.0-1_armhf.deb ...
Unpacking modemmanager (1.4.0-1) ...
Selecting previously unselected package kweb.
Preparing to unpack .../kweb_1.7.4-1_armhf.deb ...
Unpacking kweb (1.7.4-1) ...
Selecting previously unselected package rpi-youtube.
Preparing to unpack .../rpi-youtube_5.1.0-1_armhf.deb ...
Unpacking rpi-youtube (5.1.0-1) ...
Processing triggers for gnome-menus (3.13.3-6) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for dbus (1.8.20-0+deb8u1) ...
Processing triggers for install-info (5.2.0.dfsg.1-6) ...
Setting up chromium-codecs-ffmpeg-extra (51.0.2704.79-0ubuntu0.14.04.1.1121) ...
Setting up chromium-browser (51.0.2704.79-0ubuntu0.14.04.1.1121) ...
Setting up chromium-browser-l10n (51.0.2704.79-0ubuntu0.14.04.1.1121) ...
Setting up libjavascriptcoregtk-1.0-0:armhf (2.4.9-1~deb8u1+rpi1) ...
Setting up libmbim-glib4:armhf (1.10.0-2.1) ...
Setting up libmm-glib0:armhf (1.4.0-1) ...
Setting up libqmi-glib1:armhf (1.10.2-2) ...
Setting up libwebkitgtk-1.0-common (2.4.9-1~deb8u1+rpi1) ...
Setting up libwebkitgtk-1.0-0:armhf (2.4.9-1~deb8u1+rpi1) ...
Setting up geoclue-2.0 (2.1.10-2) ...
Setting up libmbim-proxy (1.10.0-2.1) ...
Setting up menu (2.1.47) ...
Setting up modemmanager (1.4.0-1) ...
Processing triggers for menu (2.1.47) ...
Setting up kweb (1.7.4-1) ...
Preparing kweb environment ...

... looking for programs needed by or recommended for Minimal Kiosk Browser
found: lxterminal
found: xpdf for better PDF support (recommended: evince!)
found: omxplayer
for use with omxplayerGUI you should always get the latest version
from http://omxplayer.sconde.net/
youtube-dl not found. It is needed for web video support.
you will be asked for automatic installation of the optimal version later on

uget download manager not found. It is highly recommended for downloads.
Install it with:
sudo apt-get install uget

if you want to use Minimal Kiosk Browser without starting the desktop,
you need the light weight task bar tint2. Install it with:
sudo apt-get install tint2

xterm not found. It can be optionally used for playing video full screen without GUI.
If you want to make use of this option, you must install it with:
sudo apt-get install xterm

Some programs needed to use all features of Minimal Kiosk Browser are not installed.
Follow the install recommendations above.

You do not have youtube-dl from github installed.
It is needed for best web video support.
Do you want to install it now? (y)ycloning git version of youtube-dl ...
Cloning into 'youtube-dl'...
remote: Counting objects: 72550, done.
remote: Compressing objects: 100% (68/68), done.
remote: Total 72550 (delta 38), reused 0 (delta 0), pack-reused 72482
Receiving objects: 100% (72550/72550), 39.98 MiB | 4.57 MiB/s, done.
Resolving deltas: 100% (52730/52730), done.
Checking connectivity... done.

creating symbolic link
compiling modules ...
Done. To update youtube-dl run update-ytdl (there are new updates almost daily)
Setting up rpi-youtube (5.1.0-1) ...
Processing triggers for libc-bin (2.19-18+deb8u4) ...
Processing triggers for dbus (1.8.20-0+deb8u1) ...
Processing triggers for menu (2.1.47) ...
pi@raspberrypi:~/work/chrome $

Chrome on Raspberry pi


notes for now to pass links over to the pi session.  rdp doesn't pass links

https://www.raspberrypi.org/forums/viewtopic.php?t=121195

Essence is to pull the binary for chrome from another site:

wget -qO - http://bintray.com/user/downloadSubjectPublicKey?username=bintray | sudo apt-key add -
echo "deb http://dl.bintray.com/kusti8/chromium-rpi jessie main" | sudo tee -a /etc/apt/sources.list
sudo apt-get update
sudo apt-get install chromium-browser rpi-youtube -y


a later version here:
 
http://kusti8.github.io/RPi-chromium/ 

Here is the output of the install included in this post

http://jim-st.blogspot.com/2016/09/output-from-installing-chrome-browser.html

Wednesday, September 7, 2016

Add printer to Raspian / Debian with CUPS

This is handy because it has instructions on how to open up the CUPS management page to your lan.

http://www.howtogeek.com/169679/how-to-add-a-printer-to-your-raspberry-pi-or-other-linux-computer/

Already on one of my pi boxes.

Steps:

sudo apt-get install cups
sudo usermod -a -G lpadmin pi

sudo vi /etc/cups/cupsd.conf

Edit lines to remove localhost,  allow local access, file it.
# Only listen for connections from the local machine
# Listen localhost:631
Port 631

    < Location / >
    # Restrict access to the server...
    Order allow,deny
    Allow @local
    < /Location >

    < Location /admin >
    # Restrict access to the admin pages...
    Order allow,deny
    Allow @local
    < /Location >

    < Location /admin/conf >
    AuthType Default
    Require user @SYSTEM

    # Restrict access to the configuration files...
    Order allow,deny
    Allow @local
    < /Location >



~

Restart cups

sudo /etc/init.d/cups restart

access cups from http://host:631/ from your local lan.



Tuesday, September 6, 2016

Changing search engine on Raspberry pi 3 (from duckduckgo to google)

original info from here:
http://www.lifehacker.com.au/2015/02/how-to-change-the-raspberry-pis-epiphany-browser-to-use-google/

sudo leafpad /usr/share/glib-2.0/schemas/org.gnome.epiphany.gschema.xml
Then locate this block of XML:
  1. <key type="s" name="keyword-search-url">
  2. <default>'https://www.google.com/search?q=%s'</default>
  3. <summary>URL Search</summary>
  4. <description>Search string for keywords entered in the URL bar.</description>
  5. </key>
The line <default>'https://duckduckgo.com/?q=%s&t=raspberrypi'</default> is what you need to change. Replace https://duckduckgo.com/?q=%s&t=raspberrypi withhttps://www.google.com.au/#q=%s
Next compile the xml with this:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas

The original article above has you install what I am guessing is the schema compiler, but that didn't work on the raspian I'm running and the compile-schemas was already there when I ran it.

Monday, September 5, 2016

Raspberry pi 3 Bluetooth

https://www.cnet.com/how-to/how-to-setup-bluetooth-on-a-raspberry-pi-3/

  • From the Raspberry Pi desktop, open a new Terminal window.
  • Type sudo bluetoothctl then press enter and input the administrator password (the default password is raspberry).
  • Next, enter agent on and press enter. Then type default-agent and press enter.
  • Type scan on and press enter one more time. The unique addresses of all the Bluetooth devices around the Raspberry Pi will appear and look something like an alphanumericXX:XX:XX:XX:XX:XX. If you make the device you want to pair discoverable (or put it into pairing mode), the device nickname may appear to the right of the address. If not, you will have to do a little trial and error or waiting to find the correct device.
  • To pair the device, type pair [device Bluetooth address]. The command will look something likepair XX:XX:XX:XX:XX:XX.
If you're pairing a keyboard, you will need to enter a six-digit string of numbers. You will see that the device has been paired, but it may not have connected. To connect the device, type connect XX:XX:XX:XX:XX:XX

Example from local pi:
pi@raspberrypi:~ $ sudo bluetoothctl
[NEW] Controller B8:27:EB:2B:C8:3A raspberrypi [default]
[NEW] Device C6:0A:5E:74:80:9E Flex
[NEW] Device 00:18:AC:38:76:BE Bluetooth Keyboard
[bluetooth]# agent on
Agent registered
[bluetooth]# default-agent
Default agent request successful
[bluetooth]# scan on
Discovery started
[CHG] Controller B8:27:EB:2B:C8:3A Discovering: yes
[NEW] Device FC:58:FA:F7:08:36 AUVIO4000449
[bluetooth]# pair FC:58:FA:F7:08:36
Attempting to pair with FC:58:FA:F7:08:36
[CHG] Device FC:58:FA:F7:08:36 Connected: yes
[CHG] Device FC:58:FA:F7:08:36 Modalias: bluetooth:v0039p13A4d0501
[CHG] Device FC:58:FA:F7:08:36 UUIDs:
        00001108-0000-1000-8000-00805f9b34fb
        0000110b-0000-1000-8000-00805f9b34fb
        0000110c-0000-1000-8000-00805f9b34fb
        0000110e-0000-1000-8000-00805f9b34fb
        0000111e-0000-1000-8000-00805f9b34fb
        0000112e-0000-1000-8000-00805f9b34fb
        00001200-0000-1000-8000-00805f9b34fb
[CHG] Device FC:58:FA:F7:08:36 Paired: yes
Pairing successful
[CHG] Device FC:58:FA:F7:08:36 Trusted: yes
[CHG] Device FC:58:FA:F7:08:36 Connected: no